Create an account

Please proceed and register to purchase and download from Smart Store.

Create account

Access SmartStore

Create an account and log in and you'll get personal extended information and instant access to all free applications in SmartStore.

Log in

Register or forgot password?

Register  Sign up here

Forgot password  Click here

Change password?


Newsletters

1123

BCS Tools 3.34

Description
BCS Tools, a complete tool for Beijer Electronics control offer including debugging, configuration, simulation and commissioning in one software. Based on CODESYS IEC 61131-3 programming with all editors (FBD, LD, IL, ST, SFC, CFC).

BCS Tools offers full customization, object-oriented graphics and user-friendly programming, with enhanced editing-control integrating application program, fieldbus and process networks into a single interface.

Four different license levels available:
• Lite
• Basic
• Professional
• Advanced

Without entering a license key, BCS Tools runs in "Lite" mode.


Update information
BCS Tools 3.34 (Current version)

New features:
• Added minimum required firmware check routine in the X2/BoX2/PIO targets.
• Added new message box to notify user if a new version is available for download.
• Added rules to allow adding only PLC compatible devices.
• Added new command Create POUs from Template.

• Added new PIO targets:
- PIO GL-9973
- PIO GL-9974
- PIO GL-9975

• Added new wizard features:
- Combo box to categorize devices during project creation.
- Fieldbus wizard configuration (protocol + slave + amount of slaves).
- Added start and stop system events in project template.

Note! Read more about enhancements and bug fixes in the attached Release Notes.

The free of charge "Lite" version 3.34 can be used for:
• X2 Control
• X2 Marine SC
• X2 Extreme SC
• BoX2 Pro SC
• BoX2 Extreme SC
• PIO GN-9372, GL-9971, GL-9972, GL-9973 and GL-9975
• NEXTO Modular (<= BCS-NX3010 without additional communication module)
• NEXTO Xpress (BCS-XP3xx)

To use all features in BCS Tools version 3.34 make sure to always use the latest firmware. Firmware versions older than stated below is not supported with the latest compiler in BCS Tools.

Minimum firmware requirements:
• X2 Control/Marine, BoX2 Pro SC image 2.0 b775 with CODESYS runtime 3.5.13.30_7
• X2 Extreme SC image 2.0 b367 with CODESYS runtime 3.5.13.30_7
• BoX2 Extreme SC image 2.0 367 with CODESYS runtime 3.5.13.30_7
• BCS NEXTO firmware 1.8.6.0 for NX3010/NX3020/NX3030
• BCS NEXTO firmware 1.9.2.0 for NX3003/NX3004/NX3005
• BCS NEXTO firmware 1.9.2.0 for XP300/XP315/XP325/XP340

Note! If you previously downloaded the software package from SmartStore, find the download link in submenu My account > My apps, when logged in!


Related documents
Release Notes - BCS Tools 3.34.pdf

Facts

General description

Version: 3.34.300.0
Release: 2022-02-20
Article: BCS Tools 3.34